summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-01 10:22:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-01 10:22:33 +0300
commitfba0fea4a68ae5905a0fdb10f0ec8134fb65d58f (patch)
treebe5fab2b79e0d4fe1806daab55117e788ffc13ca
parentb7417f3d54346981c9fd6b3985cdfbca7e167ffb (diff)
downloadpatches-fba0fea4a68ae5905a0fdb10f0ec8134fb65d58f.tar
patches-fba0fea4a68ae5905a0fdb10f0ec8134fb65d58f.tar.gz
gnu: toot: Adjust custom phases.
* gnu/packages/mastodon.scm (toot)[arguments]: 'check is already run after 'install so replace 'check rather than re-inserting it.
-rw-r--r--gnu/packages/mastodon.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index 181433091d..9f86ee5649 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -40,8 +40,7 @@
(arguments
'(#:phases
(modify-phases %standard-phases
- (delete 'check)
- (add-after 'install 'check
+ (replace 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "py.test"))))))