summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-22 00:31:22 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-23 00:06:37 +0200
commit669b8639a229eee2493bc425d124340d6424d86d (patch)
tree4c0d05a4b4dc9773ea3715111f5d0c9f2a12d637
parentcc8ddcb09771dff47c669a4e585f91c28d08359f (diff)
downloadpatches-669b8639a229eee2493bc425d124340d6424d86d.tar
patches-669b8639a229eee2493bc425d124340d6424d86d.tar.gz
gnu: commencement: Remove unneeded configure flag for bootstrap gettext.
* gnu/packages/commencement.scm (gettext-boot0): Remove unneeded --disable-threads.
-rw-r--r--gnu/packages/commencement.scm54
1 files changed, 26 insertions, 28 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 9918c21fd1..351ef3e2c4 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -421,34 +421,32 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(define gettext-boot0
;; A minimal gettext used during bootstrap.
- (let ((gettext-minimal (package
- (inherit gnu-gettext)
- (name "gettext-boot0")
- (inputs '()) ;zero dependencies
- (arguments
- (substitute-keyword-arguments
- `(#:configure-flags '("--disable-threads")
- #:tests? #f
- ,@(package-arguments gnu-gettext))
- ((#:phases phases)
- `(modify-phases ,phases
- ;; Build only the tools.
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "gettext-tools")))
-
- ;; Some test programs require pthreads,
- ;; which we don't have.
- (add-before 'configure 'no-test-programs
- (lambda _
- (substitute* "tests/Makefile.in"
- (("^PROGRAMS =.*$")
- "PROGRAMS =\n"))
- #t))
-
- ;; Don't try to link against libexpat.
- (delete 'link-expat)
- (delete 'patch-tests))))))))
+ (let ((gettext-minimal
+ (package (inherit gnu-gettext)
+ (name "gettext-boot0")
+ (inputs '()) ;zero dependencies
+ (arguments
+ (substitute-keyword-arguments
+ `(#:tests? #f
+ ,@(package-arguments gnu-gettext))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ ;; Build only the tools.
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "gettext-tools")))
+
+ ;; Some test programs require pthreads, which we don't have.
+ (add-before 'configure 'no-test-programs
+ (lambda _
+ (substitute* "tests/Makefile.in"
+ (("^PROGRAMS =.*$")
+ "PROGRAMS =\n"))
+ #t))
+
+ ;; Don't try to link against libexpat.
+ (delete 'link-expat)
+ (delete 'patch-tests))))))))
(package-with-bootstrap-guile
(package-with-explicit-inputs gettext-minimal
%boot1-inputs