summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-04-01 10:36:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-01 10:36:39 +0200
commit61e10fa8394307f461922a1cb55897422c38ce75 (patch)
treef51e85a0f2d5284385db1fd978aefe4a69938848
parent1d5c93d9f8a13588695490db6516b40f54e91fa2 (diff)
downloadpatches-61e10fa8394307f461922a1cb55897422c38ce75.tar
patches-61e10fa8394307f461922a1cb55897422c38ce75.tar.gz
gnu: Add emacs-imenu-list.
* gnu/packages/emacs-xyz.scm (emacs-imenu-list): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fa02b36644..b7aa64e733 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1978,6 +1978,31 @@ files using the dot syntax, and use Graphviz to convert these files to
diagrams.")
(license license:gpl2+))))
+(define-public emacs-imenu-list
+ (package
+ (name "emacs-imenu-list")
+ (version "0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/bmag/imenu-list")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13xh9bdl3k6ccfq83wjmkpi4269qahv4davki4wq18dr4amrzhlx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bmag/imenu-list")
+ (synopsis
+ "Automatically tracks the current buffer's imenu entries")
+ (description
+ "This Emacs minor mode creates an automatically updated buffer called
+@code{*Ilist*} that is populated with the current buffer's imenu entries.
+This buffer is typically shown as a sidebar (Emacs vertically splits the
+window).")
+ (license license:gpl3+)))
+
(define-public emacs-mmm-mode
(package
(name "emacs-mmm-mode")