summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-03-28 14:21:35 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-03-31 22:31:43 -0400
commitf1cf62f5dc829d98d1818ad6e9e55658c97fb476 (patch)
tree640406bc7e59e6bc6d5f7f42ee567f787454a166
parent284b27c5aeadb257dd8c0a33f3486c1c1eba8255 (diff)
downloadpatches-f1cf62f5dc829d98d1818ad6e9e55658c97fb476.tar
patches-f1cf62f5dc829d98d1818ad6e9e55658c97fb476.tar.gz
gnu: Add libantlr3c.
* gnu/packages/java.scm (libantlr3c): New variable. Co-authored by Maxim Cournoyer. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/java.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index c99e123795..4d305aac49 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -11,6 +11,9 @@
;;; Copyright © 2018 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+
;;;
;;; This file is part of GNU Guix.
;;;
@@ -105,6 +108,44 @@
;; build framework. We then build the more recent JDKs Icedtea 2.x and
;; Icedtea 3.x.
+(define-public libantlr3c
+ (package
+ (name "libantlr3c")
+ (version "3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.antlr3.org/download/C/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0lpbnb4dq4azmsvlhp6khq1gy42kyqyjv8gww74g5lm2y6blm4fa"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list "--enable-debuginfo" "--disable-static")
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key build target native-inputs inputs outputs
+ (configure-flags '()) out-of-source? system
+ #:allow-other-keys)
+ (let ((configure (assoc-ref %standard-phases 'configure))
+ (enable-64bit? (member system '("aarch64-linux"
+ "x86_64-linux"
+ "mips64el-linux"))))
+ (configure #:build build #:target target
+ #:native-inputs native-inputs
+ #:inputs inputs #:outputs outputs
+ #:configure-flags `(,(if enable-64bit?
+ "--enable-64bit"
+ '())
+ ,@configure-flags)
+ #:out-of-source? out-of-source?)))))))
+ (synopsis "ANTLR C Library")
+ (description "LIBANTLR3C provides run-time C libraries for ANTLR3 (ANother
+Tool for Language Recognition v3).")
+ (home-page "https://www.antlr3.org/")
+ (license license:bsd-3)))
+
(define jikes
(package
(name "jikes")