summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-03-30 16:24:37 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-03-31 17:46:55 +0100
commitf83674aa465e76e37ad17b7c2b5574b086aad6cf (patch)
treeb78a1229441d797629c25fe57b3935e12a380268
parent11ef009e7adfb53f8e76723655ff5433fe6dbadb (diff)
downloadpatches-f83674aa465e76e37ad17b7c2b5574b086aad6cf.tar
patches-f83674aa465e76e37ad17b7c2b5574b086aad6cf.tar.gz
gnu: Add perl-dynaloader-functions.
* gnu/packages/perl.scm (perl-dynaloader-functions): New variable.
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index eb02d5e05e..c16c79cde7 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3221,6 +3221,32 @@ SHA-1 message digest algorithm for use by Perl programs.")
modules separately and deal with them after the module is done installing.")
(license (package-license perl))))
+(define-public perl-dynaloader-functions
+ (package
+ (name "perl-dynaloader-functions")
+ (version "0.003")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/Z/ZE/ZEFRAM/DynaLoader-Functions-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "10x13q920j9kid7vmbj6fiaz153042dy4mwdmpzrdrxw2ir39ciy"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (home-page "https://metacpan.org/release/DynaLoader-Functions")
+ (synopsis "Deconstructed dynamic C library loading")
+ (description "This module provides a function-based interface to
+dynamic loading as used by Perl. Some details of dynamic loading are
+very platform-dependent, so correct use of these functions requires
+the programmer to be mindfulof the space of platform variations.")
+ (license perl-license)))
+
(define-public perl-encode-detect
(package
(name "perl-encode-detect")