summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-18 20:13:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-19 22:07:18 +0200
commite162050dfc0dee708a7ac5bfcf37d2afd6081604 (patch)
tree4841c2a769ea074cbb90ab0488358b476c606dd0
parent11f8e028d2fafc77be2eb58ced1680cb77b9b952 (diff)
downloadpatches-e162050dfc0dee708a7ac5bfcf37d2afd6081604.tar
patches-e162050dfc0dee708a7ac5bfcf37d2afd6081604.tar.gz
gnu: Add workaround for `date` regression in coreutils@8.26.
See <https://bugs.gnu.org/23035> and <https://bugs.gnu.org/26238>. * gnu/packages/base.scm (coreutils-8.27): New variable. * gnu/system.scm (%base-packages): Use that instead of COREUTILS.
-rw-r--r--gnu/packages/base.scm17
-rw-r--r--gnu/system.scm2
2 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 5c36b612f1..7af166d6e5 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2014, 2015 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -361,6 +362,22 @@ functionality beyond that which is outlined in the POSIX standard.")
(license gpl3+)
(home-page "https://www.gnu.org/software/coreutils/")))
+;; We add version 8.27 here for use in (gnu system) due to a time
+;; zone bug in `date' versions 8.25 - 8.26.
+;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=23035
+;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26238
+(define-public coreutils-8.27
+ (package
+ (inherit coreutils)
+ (version "8.27")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/coreutils/coreutils-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0sv547572iq8ayy8klir4hnngnx92a9nsazmf1wgzfc7xr4x74c8"))))))
+
(define-public coreutils-minimal
;; Coreutils without its optional dependencies.
(package
diff --git a/gnu/system.scm b/gnu/system.scm
index 89c4150f99..f6ab7ded85 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -385,7 +385,7 @@ explicitly appear in OS."
;; The packages below are also in %FINAL-INPUTS, so take them from
;; there to avoid duplication.
(map canonical-package
- (list guile-2.0 bash coreutils findutils grep sed
+ (list guile-2.0 bash coreutils-8.27 findutils grep sed
diffutils patch gawk tar gzip bzip2 xz lzip))))
(define %default-issue