summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-30 22:28:55 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-31 09:41:39 +0200
commit913c8897eafd5941aef65568168c51e5a0400e12 (patch)
tree80c3c0ddbf8c818fa872c5d53d7f7661c533d88e
parent3926d0fcffb3d8bf8d97507e399f3d8cd96c852f (diff)
downloadpatches-913c8897eafd5941aef65568168c51e5a0400e12.tar
patches-913c8897eafd5941aef65568168c51e5a0400e12.tar.gz
gnu: sudo: Make some inputs native.
* gnu/packages/admin.scm (sudo)[native-inputs]: New field. [inputs]: Move groff to native-inputs. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/admin.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2f661f5e81..98cb2f90aa 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1268,9 +1269,10 @@ system administrator.")
;; XXX: The 'testsudoers' test series expects user 'root' to exist, but
;; the chroot's /etc/passwd doesn't have it. Turn off the tests.
#:tests? #f))
+ (native-inputs
+ `(("groff" ,groff)))
(inputs
- `(("groff" ,groff)
- ("linux-pam" ,linux-pam)
+ `(("linux-pam" ,linux-pam)
("zlib" ,zlib)
("coreutils" ,coreutils)))
(home-page "https://www.sudo.ws/")