summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-03-31 11:06:30 +0200
committerLudovic Courtès <ludo@gnu.org>2020-03-31 14:55:42 +0200
commit8db4e704dc9c6e86c98d7357b85793dea493ff8f (patch)
treea4f4d4d3fb8dfb8b957256e2f7d1a662aae3236c
parent031610aa8abc449280673d422b2b8c6c5d194031 (diff)
downloadpatches-8db4e704dc9c6e86c98d7357b85793dea493ff8f.tar
patches-8db4e704dc9c6e86c98d7357b85793dea493ff8f.tar.gz
gnu: hwloc@2: Skip test that fails on emulated hardware.
Works around <https://bugs.gnu.org/40342>. * gnu/packages/mpi.scm (hwloc-2)[arguments]: Add 'skip-test-that-fails-on-qemu' phase.
-rw-r--r--gnu/packages/mpi.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index ec0684168e..3de2f40fda 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -158,6 +158,14 @@ bind processes, and much more.")
(substitute* "tests/hwloc/linux-libnuma.c"
(("numa_available\\(\\)")
"-1"))
+ #t))
+ (add-before 'check 'skip-test-that-fails-on-qemu
+ (lambda _
+ ;; Skip test that fails on emulated hardware due to QEMU bug:
+ ;; <https://bugs.gnu.org/40342>.
+ (substitute* "tests/hwloc/hwloc_get_last_cpu_location.c"
+ (("hwloc_topology_init" all)
+ (string-append "exit (77);\n" all)))
#t))))))))
(define-deprecated hwloc-2.0 hwloc-2)