summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-11-02 13:43:21 -0500
committerAlex Griffin <a@ajgrf.com>2019-11-11 14:03:43 -0600
commit6fcceb234633330f6e954526287788754d89118f (patch)
tree2a7a9fd6f721b131fae2458682672761d86672ec
parentaf48a2006a8be40b324977fb3f4a1b082b076e9d (diff)
downloadpatches-6fcceb234633330f6e954526287788754d89118f.tar
patches-6fcceb234633330f6e954526287788754d89118f.tar.gz
gnu: Add python-socksipychain.
* gnu/packages/python-xyz.scm (python-socksipychain, python2-socksipychain): New variables.
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1a1795a731..d7acd4811d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4453,6 +4453,35 @@ as the original project seems to have been abandoned circa 2007.")
(define-public python2-socksipy-branch
(package-with-python2 python-socksipy-branch))
+(define-public python-socksipychain
+ (package
+ (name "python-socksipychain")
+ (version "2.0.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pagekite/PySocksipyChain.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pkljnh9hfwla8sg7mil4f9zrnsqj0dbhr3crxjw3k8dnjz70dvk"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests try to access the network.
+ (home-page "http://pagekite.net/wiki/Floss/PySocksipyChain/")
+ (synopsis "Python SOCKS module with chained proxies support")
+ (description
+ "SocksiPyChain is a modified version of the SocksiPy SOCKS module, which
+adds support for arbitrary chaining of proxy servers and various modes of
+TLS/SSL encryption. It was developed for use in PageKite, and also includes
+a simple netcat replacement with chaining support.")
+ (license license:bsd-3)))
+
+(define-public python2-socksipychain
+ (package-with-python2 python-socksipychain))
+
(define-public python-pycodestyle
(package
(name "python-pycodestyle")