summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-31 14:16:53 +0200
committerLudovic Courtès <ludo@gnu.org>2020-03-31 14:55:42 +0200
commit67cbfeae30eb9b7c56145bf72582d71eea177370 (patch)
tree9a8683071f4317e729e696f2beb860988fb840c9
parent2c33901fb1f580b50d9649d5e93928172c5d12b7 (diff)
downloadpatches-67cbfeae30eb9b7c56145bf72582d71eea177370.tar
patches-67cbfeae30eb9b7c56145bf72582d71eea177370.tar.gz
gnu: coreutils: Fix cross-compilation to i586-pc-gnu.
Until now cross-compilation would fail with: i586-pc-gnu-ld: src/copy.o: undefined reference to symbol 'file_chauthor' i586-pc-gnu-ld: /gnu/store/…-glibc-cross-i586-pc-gnu-2.29/lib/libhurduser.so.0.3: error adding symbols: DSO missing from command line collect2: error: ld returned 1 exit status * gnu/packages/base.scm (coreutils)[arguments]: When 'hurd-target?', add #:configure-flags.
-rw-r--r--gnu/packages/base.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index a49ea25196..4827f80488 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -330,6 +330,13 @@ used to apply commands with arbitrarily long arguments.")
(outputs '("out" "debug"))
(arguments
`(#:parallel-build? #f ; help2man may be called too early
+
+ ;; 'cp' and others refer to 'file_chauthor' so they must link directly
+ ;; against libhurduser.
+ ,@(if (hurd-target?)
+ '(#:configure-flags '("LIBS=-lhurduser"))
+ '())
+
#:phases (modify-phases %standard-phases
(add-before 'build 'patch-shell-references
(lambda _