summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-30 22:42:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-31 14:30:39 +0200
commit5acea98e4b38ef4cdc1a8cebf6f784d9fcac9288 (patch)
treec87393ce3bdd1d7c45dd47a673e4cddca122dbad
parentf255bec6348385454ce744ffc28ded4012e7f053 (diff)
downloadpatches-5acea98e4b38ef4cdc1a8cebf6f784d9fcac9288.tar
patches-5acea98e4b38ef4cdc1a8cebf6f784d9fcac9288.tar.gz
gnu: sonic: Fix installation directories.
* gnu/packages/speech.scm (sonic)[arguments]: Replace erroneous use of DESTDIR with PREFIX. Add the required ‘rpath’ LDFLAGS together with a ‘respect-LDFLAGS’ phase.
-rw-r--r--gnu/packages/speech.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 8ee6fbfdc4..c9c1eaa8d9 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
@@ -226,12 +226,20 @@ stable and well documented interface.")
"08xwnpw9cnaix1n1i7gvpq5hrfrqc2z1snjhjapfam506hrc77g4"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; No test suite.
- #:make-flags
- (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; No ./configure script.
+ `(#:tests? #f ; no test suite
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'respect-LDFLAGS
+ (lambda _
+ (substitute* "Makefile"
+ ((" -o sonic " match)
+ (string-append " $(LDFLAGS)" match)))
+ #t))
+ (delete 'configure)))) ; no ./configure script
(synopsis "Speed up or slow down speech")
(description "Sonic implements a simple algorithm for speeding up or slowing
down speech. However, it's optimized for speed ups of over 2X, unlike previous