summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-30 22:38:44 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-31 09:41:47 +0200
commit5450e30172a977a7f0b13a48f9ee2bb681010426 (patch)
tree2592070d2570a71a0c731dac80ed7308bac61217
parent913c8897eafd5941aef65568168c51e5a0400e12 (diff)
downloadpatches-5450e30172a977a7f0b13a48f9ee2bb681010426.tar
patches-5450e30172a977a7f0b13a48f9ee2bb681010426.tar.gz
gnu: nftables: Make some inputs native.
* gnu/packages/linux.scm (procenv)[native-inputs]: New field. [inputs]: Move bison & flex to native-inputs. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 701df764cd..a45847cbe5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5647,13 +5647,13 @@ used by nftables.")
(build-system gnu-build-system)
(arguments `(#:configure-flags
'("--disable-man-doc"))) ; FIXME: Needs docbook2x.
- (inputs `(("bison" ,bison)
- ("flex" ,flex)
- ("gmp" ,gmp)
+ (inputs `(("gmp" ,gmp)
("libmnl" ,libmnl)
("libnftnl" ,libnftnl)
("readline" ,readline)))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("bison" ,bison)
+ ("flex" ,flex)))
(home-page "https://www.nftables.org")
(synopsis "Userspace utility for Linux packet filtering")
(description "nftables is the project that aims to replace the existing