summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-03-30 14:58:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-30 15:00:06 +0200
commitea5a3a43f87c639751a692651c367cdae9fc0e36 (patch)
tree4f11bc8522988913a8ea378b8810a8702c98db41
parent9a69218a1636ebdf5b456fc8025a8ad234b9f2f1 (diff)
downloadpatches-ea5a3a43f87c639751a692651c367cdae9fc0e36.tar
patches-ea5a3a43f87c639751a692651c367cdae9fc0e36.tar.gz
gnu: Add emacs-racer.
* gnu/packages/emacs-xyz.scm (emacs-racer): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 35d83476ef..cf0606aef7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16352,6 +16352,49 @@ and 'text viewing modes' respectively.")
files. It focuses on highlighting the document to improve readability.")
(license license:gpl2+)))
+(define-public emacs-racer
+ (package
+ (name "emacs-racer")
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/racer-rust/emacs-racer")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xj5iki10cg8j8vvqjlw6lfx97k3agwirhchcjnzbnkry48x9qi6"))))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("make" "test")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("\\$\\{CASK\\} exec ") ""))
+ #t)))))
+ (native-inputs
+ `(("emacs-ert-runner" ,emacs-ert-runner)
+ ("emacs-undercover" ,emacs-undercover)))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-pos-tip" ,emacs-pos-tip)
+ ("emacs-rust-mode" ,emacs-rust-mode)
+ ("emacs-s" ,emacs-s)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/racer-rust/emacs-racer")
+ (synopsis "Racer support for Emacs")
+ (description
+ "This is the official Emacs package for Racer. It supports code
+completion of variables, functions and modules. It can also jump to
+definition of functions and types, and show a help buffer based on the
+docstring of the thing at point.")
+ (license license:expat)))
+
(define-public emacs-rust-mode
(package
(name "emacs-rust-mode")