summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-30 09:39:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-03-30 10:05:51 +0300
commitdf9487c5943d923751127c20ccb2e8bec726113d (patch)
treeceaf7df0beeb9b067ebdfe10a54e232755ae46f6
parent16c62763995ccdb3165a9d5760df4097aca822fb (diff)
downloadpatches-df9487c5943d923751127c20ccb2e8bec726113d.tar
patches-df9487c5943d923751127c20ccb2e8bec726113d.tar.gz
gnu: java-modello-core: Don't use unstable tarball.
* gnu/packages/java.scm (java-modello-core)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/java.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index fe9a8998ba..5a7a75a86b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4159,12 +4159,14 @@ project and determining what files need to be rebuilt.")
(name "java-modello-core")
(version "1.9.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/codehaus-plexus/modello"
- "/archive/modello-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/codehaus-plexus/modello")
+ (commit (string-append "modello-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0l2pvns8pmlrmjm3iknp7gpg3654y1m8qhy55b19sdwdchdcyxfh"))))
+ "1di6ni42aqllpdvkpyfcw70352vr2i8wf6hd5nhd9kmqjb5dj5j4"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "modello-core.jar"