summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-30 09:08:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-03-30 10:05:51 +0300
commitd0e6461370210cc35643e0a37a7cb1c6799701ac (patch)
treed2701b175af0800909f4d25b1f602145f49fa6b2
parent48fe942c8578f52ed584691d3b581f789282a409 (diff)
downloadpatches-d0e6461370210cc35643e0a37a7cb1c6799701ac.tar
patches-d0e6461370210cc35643e0a37a7cb1c6799701ac.tar.gz
gnu: java-plexus-cipher: Don't use unstable tarball.
* gnu/packages/java.scm (java-plexus-cipher)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/java.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f04dfe0b9d..b4fb1e5a6e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3889,12 +3889,14 @@ from source tags and class annotations.")))
(name "java-plexus-cipher")
(version "1.7")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/codehaus-plexus/plexus-cipher"
- "/archive/plexus-cipher-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/codehaus-plexus/plexus-cipher")
+ (commit (string-append "plexus-cipher-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1j3r8xzlxlk340snkjp6lk2ilkxlkn8qavsfiq01f43xmvv8ymk3"))))
+ "0m638nzlxbmnbcj5cwdpgs326ab584yv0k803zlx37r6iqwvf6b0"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "plexus-cipher.jar"