summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-03-30 08:37:04 +0200
committerLeo Famulari <leo@famulari.name>2020-03-30 14:49:50 -0400
commitc8fdf86d3337fc45950ab9ac203c4f33f42153d6 (patch)
tree63841063dd08a7e2e30b3be6ae60938afd647922
parentba0b249dd898712bb59d9dea2fa881a7973e69a1 (diff)
downloadpatches-c8fdf86d3337fc45950ab9ac203c4f33f42153d6.tar
patches-c8fdf86d3337fc45950ab9ac203c4f33f42153d6.tar.gz
gnu: Add python-pypika.
Not to be confused with python-pika, which is a different package. * gnu/packages/databases.scm (python-pypika): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/databases.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 4b6c39bb19..fcc8eecd26 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3048,6 +3048,27 @@ transforms idiomatic python function calls to well-formed SQL queries.")
(define-public python2-sql
(package-with-python2 python-sql))
+(define-public python-pypika
+ (package
+ (name "python-pypika")
+ (version "0.36.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyPika" version))
+ (sha256
+ (base32
+ "0qzn5vygirg52dlizm6ayzdc5llq8p2krrx0kymr236lrz89wqp8"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-parameterized" ,python-parameterized)))
+ (home-page "https://github.com/kayak/pypika")
+ (synopsis "SQL query builder API for Python")
+ (description
+ "PyPika is a python SQL query builder that exposes the full richness of
+the SQL language using a syntax that reflects the resulting query.")
+ (license license:asl2.0)))
+
(define-public mongo-tools
(package
(name "mongo-tools")