summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-30 09:51:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-03-30 10:05:52 +0300
commit7cf26f249a40b67319cf624869e37828d9e322e5 (patch)
treed03ae494a0f6b5da5e935fe778464fb67479b0b1
parent7cf90f641981b61f9811ef6848761fe031f03b71 (diff)
downloadpatches-7cf26f249a40b67319cf624869e37828d9e322e5.tar
patches-7cf26f249a40b67319cf624869e37828d9e322e5.tar.gz
gnu: java-jmock-1: Don't use unstable tarball.
* gnu/packages/java.scm (java-jmock-1)[source]: Download using git-fetch. [home-page]: Update home-page.
-rw-r--r--gnu/packages/java.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d1cd62bf83..1a36268da7 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4528,13 +4528,14 @@ mock objects in unit testing.")
(name "java-jmock")
(version "1.2.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/jmock-developers/"
- "jmock-library/archive/" version ".tar.gz"))
- (file-name (string-append "jmock-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jmock-developers/jmock-library")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0xmrlhq0fszldkbv281k9463mv496143vvmqwpxp62yzjvdkx9w0"))))
+ "0lkga995xd9b9mmzxmcd301hlw83p1h78nibh7djlx7wydscr85z"))))
(build-system ant-build-system)
(arguments
`(#:build-target "jars"
@@ -4542,7 +4543,7 @@ mock objects in unit testing.")
#:phases
(modify-phases %standard-phases
(replace 'install (install-jars "build")))))
- (home-page "http://www.jmock.org")
+ (home-page "http://jmock.org/")
(synopsis "Mock object library for test-driven development")
(description "JMock is a library that supports test-driven development of
Java code with mock objects. Mock objects help you design and test the