summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-30 09:19:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-03-30 10:05:51 +0300
commit5723137a4cdc44c75de2d0a1d207fbf394db5530 (patch)
treec3183815ee97443589425f87139350ce1119c427
parentd0e6461370210cc35643e0a37a7cb1c6799701ac (diff)
downloadpatches-5723137a4cdc44c75de2d0a1d207fbf394db5530.tar
patches-5723137a4cdc44c75de2d0a1d207fbf394db5530.tar.gz
gnu: java-plexus-compiler-api: Don't use unstable tarball.
* gnu/packages/java.scm (java-plexus-compiler-api)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/java.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index b4fb1e5a6e..6a6af783c7 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3927,12 +3927,14 @@ and decryption.")
(name "java-plexus-compiler-api")
(version "2.8.4")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/codehaus-plexus/plexus-compiler"
- "/archive/plexus-compiler-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/codehaus-plexus/plexus-compiler")
+ (commit (string-append "plexus-compiler-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "09vmxs0807wsd26nbrwwj5l8ycmzazqycj52l7w6wjvkryywi69h"))))
+ "1nq1gnn3s6z1j29gmi1hqbklsmm8b1lmnafb0191914f95mn18gk"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "plexus-compiler-api.jar"