summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-03-30 19:11:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-30 19:11:50 +0200
commit5199be620f2a8f42fd5427ad000f8f215a852426 (patch)
tree0f5039dee2f6223c591c037ac83f10879b280167
parent0ad6ecb84b09a2821ee1d80b895aeb8a336a5b11 (diff)
downloadpatches-5199be620f2a8f42fd5427ad000f8f215a852426.tar
patches-5199be620f2a8f42fd5427ad000f8f215a852426.tar.gz
gnu: Add emacs-flycheck-rust.base-for-series-3359
* gnu/packages/emacs-xyz.scm (emacs-flycheck-rust): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cf0606aef7..c029d1ed3d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3416,6 +3416,32 @@ It also provides an easy way to find synonyms and antonyms for a given
word (to avoid repetitions for example).")
(license license:gpl3+)))
+(define-public emacs-flycheck-rust
+ (package
+ (name "emacs-flycheck-rust")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/flycheck/flycheck-rust")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fh6j5w2387nh2fwwjphkhq17cgj5m2q5k0fhidvgc2w65lzbr1r"))))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-let-alist" ,emacs-let-alist)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/flycheck/flycheck-rust")
+ (synopsis "Rust/Cargo support for Flycheck")
+ (description
+ "This Flycheck extension configures Flycheck automatically for
+the current Cargo project.")
+ (license license:gpl3+)))
+
(define-public emacs-elisp-demos
(package
(name "emacs-elisp-demos")