summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-03-30 08:39:29 +0200
committerLeo Famulari <leo@famulari.name>2020-03-30 14:49:50 -0400
commit0ab3a8c24445c634c8696717361dcd9358f7a35a (patch)
tree0278a93a16063aa08428f5d0b7acc24b177730a3
parentc8fdf86d3337fc45950ab9ac203c4f33f42153d6 (diff)
downloadpatches-0ab3a8c24445c634c8696717361dcd9358f7a35a.tar
patches-0ab3a8c24445c634c8696717361dcd9358f7a35a.tar.gz
gnu: Add python-ciso8601.
* gnu/packages/time.scm (python-ciso8601): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/time.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index f4dc8a2ffd..14f44c84c7 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -235,6 +236,34 @@ datetime module, available in Python 2.3+.")
(define-public python2-parsedatetime
(package-with-python2 python-parsedatetime))
+(define-public python-ciso8601
+ (package
+ (name "python-ciso8601")
+ (version "2.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ ;; The PyPi distribution doesn't include the tests.
+ (uri (git-reference
+ (url "https://github.com/closeio/ciso8601.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g1aiyc1ayh0rnibyy416m5mmck38ksgdm3jsy0z3rxgmgb24951"))))
+ (build-system python-build-system)
+ ;; Pytz should only be required for Python 2, but the test suite fails
+ ;; without it.
+ (native-inputs
+ `(("python-pytz" ,python-pytz)))
+ (home-page "https://github.com/closeio/ciso8601")
+ (synopsis
+ "Fast ISO8601 date time parser")
+ (description
+ "The package ciso8601 converts ISO 8601 or RFC 3339 date time strings into
+Python datetime objects.")
+ (license expat)))
+
(define-public python-tzlocal
(package
(name "python-tzlocal")