summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-29 18:35:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-29 18:40:58 +0200
commitacf900eec3772f0154d6f0b228f1d878287a10d3 (patch)
tree93a6680c4cf07e0127123f24bc71fec788d8778f
parentf020c7cc446eb0f517d0ebe1b7f0e752730ccc0c (diff)
downloadpatches-acf900eec3772f0154d6f0b228f1d878287a10d3.tar
patches-acf900eec3772f0154d6f0b228f1d878287a10d3.tar.gz
gnu: cgit: Update to 1.2.3.
* gnu/packages/version-control.scm (cgit): Update to 1.2.3. [inputs]: Update git to 2.25.1.
-rw-r--r--gnu/packages/version-control.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4da8e33e04..8af54c6e35 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -148,8 +148,6 @@ as well as the classic centralized workflow.")
(define-public git
(package
(name "git")
- ;; XXX When updating Git, check if the special 'git-source' input to cgit
- ;; needs to be updated as well.
(version "2.26.0")
(source (origin
(method url-fetch)
@@ -779,7 +777,7 @@ collaboration using typical untrusted file hosts or services.")
(package
(name "cgit")
;; Update the ‘git-source’ input as well.
- (version "1.2.2")
+ (version "1.2.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -787,7 +785,7 @@ collaboration using typical untrusted file hosts or services.")
version ".tar.xz"))
(sha256
(base32
- "0dmjsisigjz5k4gw7gm55qhm3wazzbm4cg7a5dwf0gqg9nacx5rz"))))
+ "193d990ym10qlslk0p8mjwp2j6rhqa7fq0y1iff65lvbyv914pss"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; XXX: fail to build the in-source git.
@@ -867,9 +865,9 @@ collaboration using typical untrusted file hosts or services.")
(method url-fetch)
;; cgit is tightly bound to git. Use GIT_VER from the Makefile,
;; which may not match the current (package-version git).
- (uri "mirror://kernel.org/software/scm/git/git-2.25.0.tar.xz")
+ (uri "mirror://kernel.org/software/scm/git/git-2.25.1.tar.xz")
(sha256
- (base32 "1l58v42aazj0x9276gk8r9mwyl9pgp9w99aakz4xfhzv7wd2jq60"))))
+ (base32 "09lzwa183nblr6l8ib35g2xrjf9wm9yhk3szfvyzkwivdv69c9r2"))))
("openssl" ,openssl)
("groff" ,groff)
("python" ,python)