summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-29 20:04:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-03-29 20:50:24 +0300
commita428fdd4d00849ae1575e107ac504363079e307a (patch)
tree158dd7955a00ee0d3f5b0e1964afbe25c80d4004
parentfcc8f2fc46d9c16e1849d4ef0da007a47d68b2d6 (diff)
downloadpatches-a428fdd4d00849ae1575e107ac504363079e307a.tar
patches-a428fdd4d00849ae1575e107ac504363079e307a.tar.gz
gnu: unionfs-fuse: Don't use unstable tarball.
* gnu/packages/linux.scm (unionfs-fuse)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 24d7391430..701df764cd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
@@ -2397,14 +2397,14 @@ user-space processes.")
(name "unionfs-fuse")
(version "2.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/rpodgorny/unionfs-fuse/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rpodgorny/unionfs-fuse")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0hsn8l1iblvx27bpd4dvnvnbh9ri3sv2f9xzpsnfz3379kb7skgj"))))
+ "0lb8zgdxnjy2fjr2284hvdfn7inc1in44ynzgcr66x54bxzvynj6"))))
(build-system cmake-build-system)
(native-inputs
`(("python" ,python)))