summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-21 15:59:01 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-29 22:32:54 +0200
commit9e9dd4098f7a2de658625a0e803d4955ce6ba8fd (patch)
tree3d7c8a2c5cfa44d08a56295325729220f9977ff5
parent337fc72228df2b01f024c1276703ea4369cee37d (diff)
downloadpatches-9e9dd4098f7a2de658625a0e803d4955ce6ba8fd.tar
patches-9e9dd4098f7a2de658625a0e803d4955ce6ba8fd.tar.gz
gnu: Add pocketsphinx.
* gnu/packages/speech.scm (pocketsphinx): New variable.
-rw-r--r--gnu/packages/speech.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 41010cb1dc..8ee6fbfdc4 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages emacs)
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
@@ -507,3 +508,33 @@ the CMU Sphinx trainer and all the Sphinx decoders (Sphinx-II,
Sphinx-III, and PocketSphinx), as well as some common utilities for
manipulating acoustic feature and audio files.")
(license license:bsd-4)))
+
+(define-public pocketsphinx
+ (package
+ (name "pocketsphinx")
+ (version "5prealpha")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/cmusphinx/"
+ "pocketsphinx/" version "/"
+ "pocketsphinx-" version ".tar.gz"))
+ (sha256
+ (base32 "1n9yazzdgvpqgnfzsbl96ch9cirayh74jmpjf7svs4i7grabanzg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("perl" ,perl) ;for tests
+ ("python" ,python)
+ ("swig" ,swig)))
+ (inputs
+ `(("gstreamer" ,gstreamer)
+ ("libcap" ,libcap)
+ ("pulseaudio" ,pulseaudio)
+ ("sphinxbase" ,sphinxbase)))
+ (home-page "https://cmusphinx.github.io/")
+ (synopsis "Recognizer library written in C")
+ (description "PocketSphinx is one of Carnegie Mellon University's
+large vocabulary, speaker-independent continuous speech recognition
+engine.")
+ (license license:bsd-2)))