summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru-Sergiu Marton <brown121407@gmail.com>2020-01-08 11:35:37 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-29 22:34:45 +0200
commit9989d1464f8b04dbc514d71f93630c8fe54da911 (patch)
treee929bfe155f3d9de722d834e8e89d10e2684cb5d
parentb1dbc9f5808c5383ea18c039d3dded49138370d9 (diff)
downloadpatches-9989d1464f8b04dbc514d71f93630c8fe54da911.tar
patches-9989d1464f8b04dbc514d71f93630c8fe54da911.tar.gz
gnu: Add ghc-html-conduit.
* gnu/packages/haskell-web.scm (ghc-html-conduit): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/haskell-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index acdc1447a4..d2c7b50528 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -752,6 +752,41 @@ Haskell.")
documents.")
(license license:bsd-3)))
+(define-public ghc-html-conduit
+ (package
+ (name "ghc-html-conduit")
+ (version "1.3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/html-conduit/"
+ "html-conduit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "196c8zcnjp1pc5qvqxd8arx3xkw0a90rvg9mmiw2l4zwnx65709n"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-xml-conduit" ,ghc-xml-conduit)
+ ("ghc-xml-types" ,ghc-xml-types)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/snoyberg/xml")
+ (synopsis "Parse HTML documents using xml-conduit datatypes")
+ (description
+ "This package provides a parser for HTML documents that uses
+tagstream-conduit. It automatically balances mismatched tags, so that
+there shouldn't be any parse failures. It does not handle a full HTML
+document rendering, such as adding missing html and head tags. Note that,
+since version 1.3.1, it uses an inlined copy of tagstream-conduit with
+entity decoding bugfixes applied.")
+ (license license:expat)))
+
(define-public ghc-blaze-html
(package
(name "ghc-blaze-html")