summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-05 15:37:58 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-29 21:07:28 +0200
commit8f83699ba00743d258b497e0e5285989996ee559 (patch)
treebeb70d33b4d0f4618724e25f4b6d324958b318e3
parente34b06b758f6f160494ac530a6f2e96f23719c47 (diff)
downloadpatches-8f83699ba00743d258b497e0e5285989996ee559.tar
patches-8f83699ba00743d258b497e0e5285989996ee559.tar.gz
gnu: Add flyer-composer-cli.
* gnu/packages/pdf.scm (flyer-composer-cli): New variable.
-rw-r--r--gnu/packages/pdf.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index abad204f75..e9a9b619e7 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -138,6 +138,33 @@ times. If you have a second page, Flyer Composer can arrange it the same way
This package contains both the commnd line tool and the gui too.")
(license license:agpl3+)))
+(define-public flyer-composer-cli
+ (package/inherit flyer-composer
+ (name "flyer-composer-cli")
+ (arguments
+ `(#:tests? #f ;; TODO
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-gui
+ (lambda _
+ (delete-file-recursively "flyer_composer/gui")
+ (substitute* "setup.cfg"
+ (("^\\s+flyer-composer-gui\\s*=.*") ""))
+ #t)))))
+ (inputs
+ `(("python-pypdf2" ,python-pypdf2)))
+ (description "@command{flyer-composer} can be used to prepare one- or
+two-sided flyers for printing on one sheet of paper.
+
+Imagine you have designed a flyer in A6 format and want to print it using your
+A4 printer. Of course, you want to print four flyers on each sheet. This is
+where Flyer Composer steps in, creating a PDF which holds your flyer four
+times. If you have a second page, Flyer Composer can arrange it the same way
+- even if the second page is in a separate PDF file.
+
+This package contains only the commnd line tool. If you like to use the gui,
+please install the @code{flyer-composer-gui} package.")))
+
(define-public poppler
(package
(name "poppler")