summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2020-01-23 19:26:27 -0800
committerMarius Bakke <mbakke@fastmail.com>2020-03-29 22:34:44 +0200
commit79617a0122d9fa27f193f73918859d46d6ea5cfe (patch)
tree3d2ef805a66e230c06cef62ffad8e76d75524f46
parent1e19569b41c7fa756ce1afdb1dabdfe3840cd940 (diff)
downloadpatches-79617a0122d9fa27f193f73918859d46d6ea5cfe.tar
patches-79617a0122d9fa27f193f73918859d46d6ea5cfe.tar.gz
gnu: Add apply-refact.
* gnu/packages/haskell-apps.scm (apply-refact): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/haskell-apps.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 42ceb0789b..6ab962100e 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
+;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +51,42 @@
#:use-module (gnu packages rsync)
#:use-module (gnu packages version-control))
+(define-public apply-refact
+ (package
+ (name "apply-refact")
+ (version "0.6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/apply-refact/apply-refact-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0p2mqgjcqr1zcmk8zgr0yq7g8z1agsa6l493lkj6g3ya9lyhxgig"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-refact" ,ghc-refact)
+ ("ghc-exactprint" ,ghc-exactprint)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-temporary" ,ghc-temporary)
+ ("ghc-filemanip" ,ghc-filemanip)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-optparse-applicative"
+ ,ghc-optparse-applicative)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-tasty-expected-failure"
+ ,ghc-tasty-expected-failure)
+ ("ghc-silently" ,ghc-silently)))
+ (home-page "https://hackage.haskell.org/package/apply-refact")
+ (synopsis "Perform refactorings specified by the refact library")
+ (description
+ "This package lets you perform refactorings specified by the refact
+library. It is primarily used with HLint's @code{--refactor} flag.")
+ (license license:bsd-3)))
+
;; In Stackage LTS 14, this package is at 2.4.1.0. However, that
;; version requires version 2.4.1.0 of the 'Cabal' package, which is
;; provided by GHC 8.6.5 at version 2.4.0.1. Hence, we use an older