summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-29 20:21:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-03-29 20:50:24 +0300
commit4eb40497b69909922a50d3dafdd90a0fbc7084b4 (patch)
treec33a55805d93211ed52396314234301a6df91898
parenta428fdd4d00849ae1575e107ac504363079e307a (diff)
downloadpatches-4eb40497b69909922a50d3dafdd90a0fbc7084b4.tar
patches-4eb40497b69909922a50d3dafdd90a0fbc7084b4.tar.gz
gnu: vowpal-wabbit: Don't use unstable tarball.
* gnu/packages/machine-learning.scm (vowpal-wabbit)[source]: Download using git-fetch. [arguments]: Add custom 'make-files-writable phase.
-rw-r--r--gnu/packages/machine-learning.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index beb13a81bf..3e32b3cfff 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -962,21 +962,26 @@ the following advantages:
(name "vowpal-wabbit")
(version "8.5.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/JohnLangford/vowpal_wabbit/archive/"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JohnLangford/vowpal_wabbit")
+ (commit version)))
(sha256
(base32
- "0clp2kb7rk5sckhllxjr5a651awf4s8dgzg4659yh4hf5cqnf0gr"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "04bwzk6ifgnz3fmzid8b7avxf9n5pnx9xcjm61nkjng1vv0bpj8x"))
+ (file-name (git-file-name name version))))
(inputs
`(("boost" ,boost)
("zlib" ,zlib)))
(arguments
`(#:configure-flags
(list (string-append "--with-boost="
- (assoc-ref %build-inputs "boost")))))
+ (assoc-ref %build-inputs "boost")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-files-writable
+ (lambda _
+ (for-each make-file-writable (find-files "." ".*")) #t)))))
(build-system gnu-build-system)
(home-page "https://github.com/JohnLangford/vowpal_wabbit")
(synopsis "Fast machine learning library for online learning")