summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru-Sergiu Marton <brown121407@gmail.com>2020-01-08 11:34:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-29 22:34:45 +0200
commit49bcca847825ce8c9a29949707b52f7a57f26b43 (patch)
tree0dee37f1a2ac7ae596d7978308efa0f856516af9
parentec8491b0319f417529ea6075d63e5a7782dc69f9 (diff)
downloadpatches-49bcca847825ce8c9a29949707b52f7a57f26b43.tar
patches-49bcca847825ce8c9a29949707b52f7a57f26b43.tar.gz
gnu: Add ghc-nonce.
* gnu/packages/haskell-xyz.scm (ghc-nonce): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 4ade103671..27278f1d72 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -7937,6 +7937,36 @@ class, and a lazy number type for non-negative numbers (a generalization
of Peano numbers).")
(license license:gpl3+)))
+(define-public ghc-nonce
+ (package
+ (name "ghc-nonce")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/nonce/"
+ "nonce-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1q9ph0aq51mvdvydnriqd12sfin36pfb8f588zgac1ybn8r64ksb"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-entropy" ,ghc-entropy)
+ ("ghc-unliftio" ,ghc-unliftio)
+ ("ghc-unliftio-core" ,ghc-unliftio-core)))
+ (home-page "https://github.com/prowdsponsor/nonce")
+ (synopsis "Generate cryptographic nonces in Haskell")
+ (description
+ "A nonce is an arbitrary number used only once in a cryptographic
+communication. This package contain helper functions for generating nonces.
+There are many kinds of nonces used in different situations. It's not
+guaranteed that by using the nonces from this package you won't have any
+security issues. Please make sure that the nonces generated via this
+package are usable on your design.")
+ (license license:bsd-3)))
+
(define-public ghc-numeric-extras
(package
(name "ghc-numeric-extras")