summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-14 20:32:16 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-14 23:55:50 +0100
commit31960f6fd28a3a8883fd68d5bcbce5d2d339019a (patch)
tree895019aee4baf432881d7a25fd28b4a0c2fcb117
parenta3783aca66cfd256fa361f99ebaa6b67d87a7429 (diff)
downloadpatches-31960f6fd28a3a8883fd68d5bcbce5d2d339019a.tar
patches-31960f6fd28a3a8883fd68d5bcbce5d2d339019a.tar.gz
gnu: Add emacs-helm-notmuch.
* gnu/packages/emacs-xyz.scm (emacs-helm-notmuch): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ead4c19319..9fdb00efb9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13506,3 +13506,29 @@ like @code{company}, @code{flycheck}, and @code{projectile}.")
@code{lsp-mode}, such as visual flychecking, displaying references in-line,
and code peeking.")
(license license:gpl3+)))
+
+(define-public emacs-helm-notmuch
+ (let ((commit "9988eb0f787c82c779f2417b5613b9142a5b1c9b"))
+ (package
+ (name "emacs-helm-notmuch")
+ (version (git-version "1.1" "1" commit))
+ (home-page "https://github.com/xuchunyang/helm-notmuch/")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jwhmlqlgzxj2zfz0za33vn8m2zrsmkmnq2vx5i1nry70p9h43b4"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("notmuch" ,notmuch)))
+ (synopsis "Search emails with Emacs Notmuch and Helm")
+ (description
+ "This package can be used to search emails in Emacs, searching result
+displays as you type thanks to Helm, though @command{notmuch-search} does the
+real search.")
+ (license license:gpl3+))))