summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-29 21:15:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-29 22:34:44 +0200
commit1e19569b41c7fa756ce1afdb1dabdfe3840cd940 (patch)
tree173377fa9d72a91aee18f0f1294fc2e060572cc4
parent9e9dd4098f7a2de658625a0e803d4955ce6ba8fd (diff)
downloadpatches-1e19569b41c7fa756ce1afdb1dabdfe3840cd940.tar
patches-1e19569b41c7fa756ce1afdb1dabdfe3840cd940.tar.gz
gnu: Move the deprecated 'ghc-stylish-haskell' closer to its replacement.
Inheritance across modules can cause unbound variable errors because of cyclic dependencies between the modules. * gnu/packages/haskell-xyz.scm (ghc-stylish-haskell): Move from here ... * gnu/packages/haskell-apps.scm (ghc-stylish-haskell): ... to here.
-rw-r--r--gnu/packages/haskell-apps.scm3
-rw-r--r--gnu/packages/haskell-xyz.scm3
2 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 12cb857cbb..42ceb0789b 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -777,3 +777,6 @@ Replace some ASCII sequences by their Unicode equivalent (turned off by
default)
@end itemize")
(license license:bsd-3)))
+
+(define-public ghc-stylish-haskell
+ (deprecated-package "ghc-stylish-haskell" stylish-haskell))
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0828dc93c6..f2d0222fcb 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11118,9 +11118,6 @@ functions for breaking or splitting on substrings and replacing all
occurrences of a substring (the first in case of overlaps) with another.")
(license license:bsd-3)))
-(define-public ghc-stylish-haskell
- (deprecated-package "ghc-stylish-haskell" stylish-haskell))
-
(define-public ghc-svg-builder
(package
(name "ghc-svg-builder")