summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-29 22:40:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-29 22:40:53 +0200
commit1a17d21b24f56a02282821fc04cca54637d84170 (patch)
tree2433e61fdad8ca0a9d15f6432abb6bd5071e914d
parent3bf45ff4e00ec8b5d0b2848b8298812402709354 (diff)
downloadpatches-1a17d21b24f56a02282821fc04cca54637d84170.tar
patches-1a17d21b24f56a02282821fc04cca54637d84170.tar.gz
gnu: Add parlatype.
* gnu/packages/gnome.scm (parlatype): New variable.
-rw-r--r--gnu/packages/gnome.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 924b38dc6f..6178ee1010 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9884,3 +9885,60 @@ to.")
license:public-domain
;; snowball
license:bsd-2))))
+
+(define-public parlatype
+ ;; This is one commit away from 2.0, because the latter introduced
+ ;; a regression in ASR.
+ (let ((commit "7d22ead13ef7578f99d24146663cc1bdb7d8c2a9")
+ (revision "0"))
+ (package
+ (name "parlatype")
+ (version (git-version "2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gkarsay/parlatype.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r3k3qczbzi7bs5s1rddhpsnadyr805df40bqkx0srlxgh5mfghf"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:tests? #f ;require internet access
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-parlatype
+ ;; Add gstreamer plugin provided in this package to system's
+ ;; plugins.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (string-append
+ out "/lib/gstreamer-1.0/"
+ ":"
+ (getenv "GST_PLUGIN_SYSTEM_PATH"))))
+ (wrap-program (string-append out "/bin/parlatype")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" = (,gst-plugin-path))))
+ #t)))))
+ (native-inputs
+ `(("appstream-glib" ,appstream-glib)
+ ("desktop-file-utils" ,desktop-file-utils) ;for desktop-file-validate
+ ("gettext" ,gettext-minimal)
+ ("glib" ,glib "bin") ;for glib-compile-resources
+ ("pkg-config" ,pkg-config)
+ ("yelp-tools" ,yelp-tools)))
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("gstreamer" ,gstreamer)
+ ("gtk+" ,gtk+)
+ ("pocketsphinx" ,pocketsphinx)
+ ("pulseaudio" ,pulseaudio)
+ ("sphinxbase" ,sphinxbase)))
+ (home-page "http://gkarsay.github.io/parlatype/")
+ (synopsis "GNOME audio player for transcription")
+ (description "Parlatype is an audio player for the GNOME desktop
+environment. Its main purpose is the manual transcription of spoken
+audio files.")
+ (license license:gpl3+))))