summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 19:36:47 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-03-14 22:09:50 +0100
commitd2203187feaa0d3c7ebc9c9f1c49cd0788615f01 (patch)
treec0a93b15dcd3ab016e9b7b47bd138e3fd509b153
parent250ac438e79076410964bbe9e091ae39dea1c4d0 (diff)
downloadpatches-d2203187feaa0d3c7ebc9c9f1c49cd0788615f01.tar
patches-d2203187feaa0d3c7ebc9c9f1c49cd0788615f01.tar.gz
gnu: Add ocaml-ppx-let.
* gnu/packages/ocaml.scm (ocaml-ppx-let): New variable.
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 23590054e0..a12d198089 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2441,3 +2441,23 @@ variant types.")
for the list of all values of a type (for a type which only has finitely
many values).")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-let
+ (package
+ (name "ocaml-ppx-let")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_let" version
+ "0gd6d3gdaqfwjcs7gaw1qxc30i584q6a86ndaj1bx1q63xqd6yx9"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-driver" ,ocaml-ppx-driver)
+ ("ppx-core" ,ocaml-ppx-core)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_let")
+ (synopsis "Monadic let-bindings")
+ (description "A ppx rewriter for monadic and applicative let bindings,
+match expressions, and if expressions.")
+ (license license:asl2.0)))