summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-02-28 11:11:47 +0000
committerLudovic Courtès <ludo@gnu.org>2017-03-14 10:28:57 +0100
commita4651f64117766abae659af848802d91cf607e17 (patch)
tree687d3427595ff7275cf1510b21c80e3ca83f0c9b
parent944a5cdd0d8a659b675ec73e7cfa983048c96ed5 (diff)
downloadpatches-a4651f64117766abae659af848802d91cf607e17.tar
patches-a4651f64117766abae659af848802d91cf607e17.tar.gz
gnu: Add dovecot-libsodium-plugin.
* gnu/packages/mail.scm (dovecot-libsodium-plugin): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/mail.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 02147b3108..fa8a3aae6b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1187,6 +1187,48 @@ using lidsodium sealed boxes.
@end enumerate\n")
(license agpl3))))
+(define-public dovecot-libsodium-plugin
+ (let ((commit "044de73c01c35385df0105f6b387bec5d5317ce7")
+ (revision "1"))
+ (package
+ (name "dovecot-libsodium-plugin")
+ (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LuckyFellow/dovecot-libsodium-plugin")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "13h07l7xy713zchnj2p9fhvq7fdl4zy1ai94li3ygkqjjj8hrgas"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)
+ ("dovecot" ,dovecot)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libsodium" ,libsodium)))
+ (arguments
+ `(#:tests? #f ;No tests exist.
+ #:configure-flags (list (string-append "--with-dovecot="
+ (assoc-ref %build-inputs "dovecot")
+ "/lib/dovecot"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'autogen
+ (lambda _
+ (zero? (system* "./autogen.sh")))))))
+ (home-page "https://github.com/LuckyFellow/dovecot-libsodium-plugin")
+ (synopsis "Libsodium password hashing schemes plugin for Dovecot")
+ (description
+ "@code{dovecot-libsodium-plugin} provides libsodium password
+hashing schemes plugin for @code{Dovecot}.")
+ (license gpl3+))))
+
(define-public isync
(package
(name "isync")