summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 19:30:07 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-03-14 22:09:46 +0100
commita43160ee6f12a8dd8540ef674472acabf4b192d9 (patch)
tree1310706ad6c246d6db2faca95a580f40708dde0f
parent651563bd71ba40d35507f42493dd5a6ff9a94077 (diff)
downloadpatches-a43160ee6f12a8dd8540ef674472acabf4b192d9.tar
patches-a43160ee6f12a8dd8540ef674472acabf4b192d9.tar.gz
gnu: Add ocaml-ppx-assert.
* gnu/packages/ocaml.scm (ocaml-ppx-assert): New variable.
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index fa9fb51155..c3ee884549 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2394,3 +2394,28 @@ variant types.")
(synopsis "Expands [%here] into its location")
(description "Expands [%here] into its location.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-assert
+ (package
+ (name "ocaml-ppx-assert")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_assert" version
+ "1k5kxmqkibp5fk25pgz81f3c1r4mgvb5byzf6bnmxd24y60wn46p"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-compare" ,ocaml-ppx-compare)
+ ("ppx-core" ,ocaml-ppx-core)
+ ("ppx-driver" ,ocaml-ppx-driver)
+ ("ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("ppx-tools" ,ocaml-ppx-tools)
+ ("ppx-type-conv" ,ocaml-ppx-type-conv)
+ ("ppx-sexplib" ,ocaml-sexplib)
+ ("ppx-here" ,ocaml-ppx-here)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_assert")
+ (synopsis "Assert-like extension nodes that raise useful errors on failure")
+ (description "Assert-like extension nodes that raise useful errors on failure.")
+ (license license:asl2.0)))