summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-14 22:25:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-14 22:29:18 +0100
commit796d2f2d0b86a49e3b6ec89de406aa8ec19f0eda (patch)
tree7a0650eb940bb98f227cbc8ee277e0c9aa88e43d
parent031349075a5b7b40d85059aed6113c926babdc7f (diff)
downloadpatches-796d2f2d0b86a49e3b6ec89de406aa8ec19f0eda.tar
patches-796d2f2d0b86a49e3b6ec89de406aa8ec19f0eda.tar.gz
Revert "gnu: nss: Use 'modify-phases' syntax."
This reverts commit 87f1c7efc18f8996b0b2817a5f7b84eebe2ddf5a.
-rw-r--r--gnu/packages/gnuzilla.scm91
1 files changed, 47 insertions, 44 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index e11e831cbe..e6e24f6650 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -221,52 +221,55 @@ in the Mozilla clients.")
(ice-9 match)
(srfi srfi-26))
#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key system inputs #:allow-other-keys)
- (setenv "CC" "gcc")
- ;; Tells NSS to build for the 64-bit ABI if we are 64-bit system.
- (when (string-prefix? "x86_64" system)
- (setenv "USE_64" "1"))
- #t))
- (replace 'check
- (lambda _
- ;; Use 127.0.0.1 instead of $HOST.$DOMSUF as HOSTADDR for testing.
- ;; The later requires a working DNS or /etc/hosts.
- (setenv "DOMSUF" "(none)")
- (setenv "USE_IP" "TRUE")
- (setenv "IP_ADDRESS" "127.0.0.1")
- (zero? (system* "./nss/tests/all.sh"))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append (assoc-ref outputs "bin") "/bin"))
- (inc (string-append out "/include/nss"))
- (lib (string-append out "/lib/nss"))
- (obj (match (scandir "dist" (cut string-suffix? "OBJ" <>))
- ((obj) (string-append "dist/" obj)))))
- ;; Install nss-config to $out/bin.
- (install-file (string-append obj "/bin/nss-config")
- (string-append out "/bin"))
- (delete-file (string-append obj "/bin/nss-config"))
- ;; Install nss.pc to $out/lib/pkgconfig.
- (install-file (string-append obj "/lib/pkgconfig/nss.pc")
- (string-append out "/lib/pkgconfig"))
- (delete-file (string-append obj "/lib/pkgconfig/nss.pc"))
- (rmdir (string-append obj "/lib/pkgconfig"))
- ;; Install other files.
- (copy-recursively "dist/public/nss" inc)
- (copy-recursively (string-append obj "/bin") bin)
- (copy-recursively (string-append obj "/lib") lib)
+ (alist-replace
+ 'configure
+ (lambda* (#:key system inputs #:allow-other-keys)
+ (setenv "CC" "gcc")
+ ;; Tells NSS to build for the 64-bit ABI if we are 64-bit system.
+ (when (string-prefix? "x86_64" system)
+ (setenv "USE_64" "1"))
+ #t)
+ (alist-replace
+ 'check
+ (lambda _
+ ;; Use 127.0.0.1 instead of $HOST.$DOMSUF as HOSTADDR for testing.
+ ;; The later requires a working DNS or /etc/hosts.
+ (setenv "DOMSUF" "(none)")
+ (setenv "USE_IP" "TRUE")
+ (setenv "IP_ADDRESS" "127.0.0.1")
+ (zero? (system* "./nss/tests/all.sh")))
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append (assoc-ref outputs "bin") "/bin"))
+ (inc (string-append out "/include/nss"))
+ (lib (string-append out "/lib/nss"))
+ (obj (match (scandir "dist" (cut string-suffix? "OBJ" <>))
+ ((obj) (string-append "dist/" obj)))))
+ ;; Install nss-config to $out/bin.
+ (install-file (string-append obj "/bin/nss-config")
+ (string-append out "/bin"))
+ (delete-file (string-append obj "/bin/nss-config"))
+ ;; Install nss.pc to $out/lib/pkgconfig.
+ (install-file (string-append obj "/lib/pkgconfig/nss.pc")
+ (string-append out "/lib/pkgconfig"))
+ (delete-file (string-append obj "/lib/pkgconfig/nss.pc"))
+ (rmdir (string-append obj "/lib/pkgconfig"))
+ ;; Install other files.
+ (copy-recursively "dist/public/nss" inc)
+ (copy-recursively (string-append obj "/bin") bin)
+ (copy-recursively (string-append obj "/lib") lib)
- ;; FIXME: libgtest1.so is installed in the above step, and it's
- ;; (unnecessarily) linked with several NSS libraries, but
- ;; without the needed rpaths, causing the 'validate-runpath'
- ;; phase to fail. Here we simply delete libgtest1.so, since it
- ;; seems to be used only during the tests.
- (delete-file (string-append lib "/libgtest1.so"))
+ ;; FIXME: libgtest1.so is installed in the above step, and it's
+ ;; (unnecessarily) linked with several NSS libraries, but
+ ;; without the needed rpaths, causing the 'validate-runpath'
+ ;; phase to fail. Here we simply delete libgtest1.so, since it
+ ;; seems to be used only during the tests.
+ (delete-file (string-append lib "/libgtest1.so"))
- #t))))))
+ #t))
+ %standard-phases)))))
(inputs
`(("sqlite" ,sqlite)
("zlib" ,zlib)))