summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-29 15:05:18 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-26 16:25:11 +1000
commitacb6be429850187ecf078579de19557a9ff31eec (patch)
tree2eb4e7535c48f0e00e330b0877caf90d05d870bb
parentf3e085a8d57070f7507b6a4624221fbec4c8addf (diff)
downloadpatches-acb6be429850187ecf078579de19557a9ff31eec.tar
patches-acb6be429850187ecf078579de19557a9ff31eec.tar.gz
gnu: Add ruby-ascii85.
* gnu/packages/ruby.scm (ruby-ascii85): New variable.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e1a36aa3db..45d2343cdf 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3254,3 +3254,25 @@ specific use case.")
files and use the data therein.")
(home-page "http://github.com/halfbyte/afm")
(license license:expat)))
+
+(define-public ruby-ascii85
+ (package
+ (name "ruby-ascii85")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "Ascii85" version))
+ (sha256
+ (base32
+ "0j95sbxd18kc8rhcnvl1w37kflqpax1r12h1x47gh4xxn3mz4m7q"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis "Encode and decode Ascii85 binary-to-text encoding")
+ (description
+ "This library provides methods to encode and decode Ascii85
+binary-to-text encoding. The main modern use of Ascii85 is in PostScript and
+@dfn{Portable Document Format} (PDF) file formats.")
+ (home-page "https://github.com/datawraith/ascii85gem")
+ (license license:expat)))