summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodor Kondić <tk.code@protonmail.com>2020-03-25 15:38:50 -0400
committerLeo Famulari <leo@famulari.name>2020-03-25 15:46:02 -0400
commit6ad80b2a6b25178e94f7bae194c0007215398968 (patch)
tree8e392e1b6fb618f17bc84d458abbbd68f7d989e1
parent49a8ef8ae1e43fd3a125b782bf49e1d2383ae71f (diff)
downloadpatches-6ad80b2a6b25178e94f7bae194c0007215398968.tar
patches-6ad80b2a6b25178e94f7bae194c0007215398968.tar.gz
gnu: Add r-getpass.
* gnu/packages/cran.scm (r-getpass): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4e67c5104a..3447859f01 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20967,3 +20967,28 @@ service. Functions are provided to work with the OAI-PMH verbs:
(description
"Utilities for secure password hashing via the argon2 algorithm.")
(license license:bsd-2)))
+
+(define-public r-getpass
+ (package
+ (name "r-getpass")
+ (version "0.2-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "getPass" version))
+ (sha256
+ (base32
+ "03ydafhh0sk3rcnpr3paajyji64x2ddp6p814p9mvbmyrblcgzcc"))))
+ (properties `((upstream-name . "getPass")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rstudioapi" ,r-rstudioapi)))
+ (home-page
+ "https://github.com/wrathematics/getPass")
+ (synopsis "Masked User Input")
+ (description
+ "This package provides a micro-package for reading \"passwords\", i.e.
+reading user input with masking, so that the input is not displayed as it is
+typed. Currently, RStudio, the command line (every OS), and any platform
+where tcltk is present are supported.")
+ (license license:bsd-2)))