summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-10-01 08:52:34 -0400
committerLeo Famulari <leo@famulari.name>2018-10-01 09:08:11 -0400
commit63ec2c505a29ee8c7c6a7633b054edc41dbc95fa (patch)
treeb203eba8c3ec86a633779c8faccf537e433e205e
parent16c5285af40f66614cccfe3f916cfe78e49bae16 (diff)
downloadpatches-63ec2c505a29ee8c7c6a7633b054edc41dbc95fa.tar
patches-63ec2c505a29ee8c7c6a7633b054edc41dbc95fa.tar.gz
gnu: Add r-physicalactivity.
* gnu/packages/cran.scm (r-physicalactivity): New variable.
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b06d22bd51..932d7cb414 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5991,3 +5991,36 @@ search and trust region. There are options for using a numerical or user
supplied Jacobian, for specifying a banded numerical Jacobian and for allowing a
singular or ill-conditioned Jacobian.")
(license license:gpl2+)))
+
+(define-public r-physicalactivity
+ (package
+ (name "r-physicalactivity")
+ (version "0.2-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "PhysicalActivity" version))
+ (sha256
+ (base32 "14z6plgwyr46vs9m997rvlz8sdglfs9g087an8668zqkzzs2w4ln"))))
+ (properties
+ `((upstream-name . "PhysicalActivity")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/PhysicalActivity/")
+ (synopsis "Procesing accelerometer data for physical activity measurement")
+ (description
+ "This @code{r-physicalactivity} package provides a function @code{wearingMarking}
+for classification of monitor wear and nonwear time intervals in accelerometer
+data collected to assess physical activity. The package also contains functions
+for making plots of accelerometer data and obtaining the summary of various
+information including daily monitor wear time and the mean monitor wear time
+during valid days. The revised package version 0.2-1 improved the functions
+regarding speed, robustness and add better support for time zones and daylight
+saving. In addition, several functions were added:
+@enumerate
+@item the @code{markDelivery} can classify days for ActiGraph delivery by mail;
+@item the @code{markPAI} can categorize physical activity intensity level based
+on user-defined cut-points of accelerometer counts.
+@end enumerate
+ It also supports importing ActiGraph (AGD) files with @code{readActigraph} and
+@code{queryActigraph} functions.")
+ (license license:gpl3+)))