summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodor Kondić <tk.code@protonmail.com>2020-03-25 15:37:55 -0400
committerLeo Famulari <leo@famulari.name>2020-03-25 15:45:54 -0400
commit49a8ef8ae1e43fd3a125b782bf49e1d2383ae71f (patch)
tree968a293f9359df27abf98bd75187502bf23198ab
parent0557618dbea23afc1d2a0ee2d43d504c35e2f089 (diff)
downloadpatches-49a8ef8ae1e43fd3a125b782bf49e1d2383ae71f.tar
patches-49a8ef8ae1e43fd3a125b782bf49e1d2383ae71f.tar.gz
gnu: Add r-argon2.
* gnu/packages/cran.scm (r-argon2): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 30d2ba30d0..4e67c5104a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2020 Todor Kondić <tk.code@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20946,3 +20947,23 @@ service. Functions are provided to work with the OAI-PMH verbs:
@code{GetRecord}, @code{Identify}, @code{ListIdentifiers},
@code{ListMetadataFormats}, @code{ListRecords}, and @code{ListSets}.")
(license license:expat)))
+
+(define-public r-argon2
+ (package
+ (name "r-argon2")
+ (version "0.2-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "argon2" version))
+ (sha256
+ (base32
+ "0kqn06rpb39jlzizjlnc5c44mfic8llrshxn7ljgmyj35lbqwxqh"))))
+ (properties `((upstream-name . "argon2")))
+ (build-system r-build-system)
+ (home-page
+ "https://github.com/wrathematics/argon2")
+ (synopsis "Secure Password Hashing based on Argon2 Algorithm")
+ (description
+ "Utilities for secure password hashing via the argon2 algorithm.")
+ (license license:bsd-2)))