summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodor Kondić <tk.code@protonmail.com>2020-03-25 15:39:08 -0400
committerLeo Famulari <leo@famulari.name>2020-03-25 15:46:02 -0400
commit0c549393b9b9194f47fbee2bdfa1caf8f4e32b12 (patch)
tree79665c288d512775320c62001458db08d09221dc
parent6ad80b2a6b25178e94f7bae194c0007215398968 (diff)
downloadpatches-0c549393b9b9194f47fbee2bdfa1caf8f4e32b12.tar
patches-0c549393b9b9194f47fbee2bdfa1caf8f4e32b12.tar.gz
gnu: Add r-remoter.
* gnu/packages/cran.scm (r-remoter): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3447859f01..c0bd4bfd4f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20992,3 +20992,30 @@ reading user input with masking, so that the input is not displayed as it is
typed. Currently, RStudio, the command line (every OS), and any platform
where tcltk is present are supported.")
(license license:bsd-2)))
+
+(define-public r-remoter
+ (package
+ (name "r-remoter")
+ (version "0.4-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "remoter" version))
+ (sha256
+ (base32
+ "1a7m63l8phv5jnazvdqdrqkaqjwqzaac5y4jm2jn0ypy4n8jvkfl"))))
+ (properties `((upstream-name . "remoter")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-argon2" ,r-argon2)
+ ("r-getpass" ,r-getpass)
+ ("r-pbdzmq" ,r-pbdzmq)
+ ("r-png" ,r-png)))
+ (home-page "https://github.com/RBigData/remoter")
+ (synopsis
+ "Control a Remote R Session from a Local One")
+ (description
+ "This package provides a set of utilities for client/server computing
+with R, controlling a remote R session (the server) from a local one (the
+client).")
+ (license license:bsd-2)))