summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2017-08-07 15:20:37 +0800
committerRicardo Wurmus <rekado@elephly.net>2017-08-16 17:07:39 +0200
commite0ca14c7a8557e3b96ad70fa43b8777ce4835ac5 (patch)
treee3e0c8f85deb2af44707571315aa4072fd48d63e
parent298af2a8da1b12ee206d8e81f68db6f3351a41d3 (diff)
downloadpatches-e0ca14c7a8557e3b96ad70fa43b8777ce4835ac5.tar
patches-e0ca14c7a8557e3b96ad70fa43b8777ce4835ac5.tar.gz
gnu: Add ghc-geniplate-mirror.
* gnu/packages/haskell.scm (ghc-geniplate-mirror): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7ed503ab92..14cc228d5f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5775,6 +5775,28 @@ and @code{Eq} instances. These instances used to live in the haskell-src-meta
package, and that's where the version number started.")
(license license:bsd-3)))
+(define-public ghc-geniplate-mirror
+ (package
+ (name "ghc-geniplate-mirror")
+ (version "0.7.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package"
+ "/geniplate-mirror"
+ "/geniplate-mirror-" version ".tar.gz"))
+ (sha256
+ (base32 "17vjps2118s5z3k39ij00lkmkxv3mqf8h59wv6qdamlgmhyr36si"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-mtl" ,ghc-mtl)))
+ (home-page "https://github.com/danr/geniplate")
+ (synopsis "Use Template Haskell to generate Uniplate-like functions")
+ (description
+ "Use Template Haskell to generate Uniplate-like functions. This is a
+maintained mirror of the @uref{https://hackage.haskell.org/package/geniplate,
+geniplate} package, written by Lennart Augustsson.")
+ (license license:bsd-3)))
+
(define-public ghc-haskell-src-meta
(package
(name "ghc-haskell-src-meta")