summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2017-08-07 15:05:36 +0800
committerRicardo Wurmus <rekado@elephly.net>2017-08-16 17:07:38 +0200
commita623fd7fedcc4ea4e3b86f7fdf04872b9c5042de (patch)
treef61ddaecf0b6a4ab789ffbb8da9322fb08af0f21
parentca48a3459413edd3a337b554ac0499c9f12364e6 (diff)
downloadpatches-a623fd7fedcc4ea4e3b86f7fdf04872b9c5042de.tar
patches-a623fd7fedcc4ea4e3b86f7fdf04872b9c5042de.tar.gz
gnu: Add ghc-murmur-hash.
* gnu/packages/haskell.scm (ghc-murmur-hash): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 00c5994016..971981daae 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1881,6 +1881,28 @@ combine hash values.")
It includes hashing functions for all basic Haskell98 types.")
(license license:bsd-3)))
+(define-public ghc-murmur-hash
+ (package
+ (name "ghc-murmur-hash")
+ (version "0.1.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/murmur-hash"
+ "/murmur-hash-" version ".tar.gz"))
+ (sha256
+ (base32 "1bb58kfnzvx3mpc0rc0dhqc1fk36nm8prd6gvf20gk6lxaadpfc9"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/nominolo/murmur-hash")
+ (synopsis "MurmurHash2 implementation for Haskell")
+ (description
+ "This package provides an implementation of MurmurHash2, a good, fast,
+general-purpose, non-cryptographic hashing function. See
+@url{https://sites.google.com/site/murmurhash/} for details. This
+implementation is pure Haskell, so it might be a bit slower than a C FFI
+binding.")
+ (license license:bsd-3)))
+
(define-public ghc-hunit
(package
(name "ghc-hunit")