summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-03 11:31:46 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-04 00:46:04 -0500
commit996f41102f2ff83a045d4580da10ad15eb64ac3c (patch)
treeaef9f8a70a619286c306efa597e358f30bad34e1
parent47533b6f699dc572d43c8a5cf96d9d02bae4a023 (diff)
downloadpatches-996f41102f2ff83a045d4580da10ad15eb64ac3c.tar
patches-996f41102f2ff83a045d4580da10ad15eb64ac3c.tar.gz
gnu: Add Catalyst-Plugin-StackTrace.
* gnu/packages/web.scm (perl-catalyst-plugin-stacktrace): New variable.
-rw-r--r--gnu/packages/web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b1593676f7..67167a7238 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -925,6 +925,31 @@ storage plugin for Catalyst that uses an mmap'ed file to act as a shared
memory interprocess cache. It is based on Cache::FastMmap.")
(license (package-license perl))))
+(define-public perl-catalyst-plugin-stacktrace
+ (package
+ (name "perl-catalyst-plugin-stacktrace")
+ (version "0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/B/BO/BOBTFISH/"
+ "Catalyst-Plugin-StackTrace-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1b2ksz74cpigxqzf63rddar3vfmnbpwpdcbs11v0ml89pb8ar79j"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-catalyst-runtime" ,perl-catalyst-runtime)
+ ("perl-devel-stacktrace" ,perl-devel-stacktrace)
+ ("perl-mro-compat" ,perl-mro-compat)))
+ (home-page "http://search.cpan.org/dist/Catalyst-Plugin-StackTrace")
+ (synopsis "Stack trace on the Catalyst debug screen")
+ (description "This plugin enhances the standard Catalyst debug screen by
+including a stack trace of your appliation up to the point where the error
+occurred. Each stack frame is displayed along with the package name, line
+number, file name, and code context surrounding the line number.")
+ (license (package-license perl))))
+
(define-public perl-catalyst-plugin-static-simple
(package
(name "perl-catalyst-plugin-static-simple")