summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-24 00:54:39 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-24 18:10:46 +0200
commit8ae540a2c024f9b1b8bce65dbe1dfbf4e926bc77 (patch)
tree5170efa33b604f6941981f21825d3202450a406f
parent000147811b15465cd0f67d2635ba7d807d865afd (diff)
downloadpatches-8ae540a2c024f9b1b8bce65dbe1dfbf4e926bc77.tar
patches-8ae540a2c024f9b1b8bce65dbe1dfbf4e926bc77.tar.gz
gnu: ocaml-ssl: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-ssl)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/ocaml.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7859696406..0756aecd6d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -65,6 +65,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system ocaml)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix svn-download)
@@ -1650,12 +1651,13 @@ lets the client choose the concrete timeline.")
(version "0.5.5")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/savonet/ocaml-ssl/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/savonet/ocaml-ssl.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256 (base32
- "15p7652cvzdrlqxc1af11mg07wasxr1fsaj44gcmmh6bmav7wfzq"))))
+ "0fviq8xhp3qk7pmkl7knchywsipxgb7p0z489hj8qnf2sx8xzdmy"))))
(build-system ocaml-build-system)
(arguments `(#:tests? #f
#:make-flags (list "OCAMLFIND_LDCONF=ignore")