summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-05 17:42:19 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:41 -0500
commit8428e92c55653eced5323d4414b0ea17d067ba78 (patch)
treef7b98cc2a2904f55138eb6dddcb7f77fea8e50c9
parent2f9be5e7dd23d1d44290ff48e06a42cd2f4bce5a (diff)
downloadpatches-8428e92c55653eced5323d4414b0ea17d067ba78.tar
patches-8428e92c55653eced5323d4414b0ea17d067ba78.tar.gz
gnu: Add ghc-zstd.
* gnu/packages/haskell-xyz.scm (ghc-zstd): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0da0212e50..9115afd0c5 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -12263,3 +12263,28 @@ provides access to the full zlib feature set.")
(description "This package provides low-level bindings to the
@code{zlib} package.")
(license license:bsd-3)))
+
+(define-public ghc-zstd
+ (package
+ (name "ghc-zstd")
+ (version "0.1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "zstd/zstd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "147s496zvw13akxqzg65mgfvk3bvhrcilxgf8n786prxg5cm4jz2"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ (home-page "https://github.com/luispedro/hs-zstd")
+ (synopsis "Haskell bindings to the Zstandard compression algorithm")
+ (description "This library provides Haskell bindings to the
+Zstandard compression algorithm, a fast lossless compression algorithm
+targeting real-time compression scenarios at zlib-level and better
+compression ratios.")
+ (license license:bsd-3)))