summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 12:26:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:20 +0100
commit7d416066cd4c0a6fb947ab9b77e87e2dbf2f5d23 (patch)
treeb7080fd2abd44844684814295151b25efdc11359
parent4c523c45353095d389f1093725069a6475c4f1b3 (diff)
downloadpatches-7d416066cd4c0a6fb947ab9b77e87e2dbf2f5d23.tar
patches-7d416066cd4c0a6fb947ab9b77e87e2dbf2f5d23.tar.gz
gnu: ccl: Unconditionally return #T from build phases.
* gnu/packages/lisp.scm (ccl)[arguments]: Use INVOKE and return #T from build phases.
-rw-r--r--gnu/packages/lisp.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 05f325e60d..465454aad6 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -505,8 +505,9 @@ statistical profiler, a code coverage tool, and many other extensions.")
(modify-phases %standard-phases
(replace 'unpack
(lambda* (#:key inputs #:allow-other-keys)
- (and (zero? (system* "tar" "xzvf" (assoc-ref inputs "ccl")))
- (begin (chdir "ccl") #t))))
+ (invoke "tar" "xzvf" (assoc-ref inputs "ccl"))
+ (chdir "ccl")
+ #t))
(delete 'configure)
(add-before 'build 'pre-build
;; Enter the source directory for the current platform's lisp
@@ -527,7 +528,7 @@ statistical profiler, a code coverage tool, and many other extensions.")
(substitute* '("Makefile")
(("/bin/rm") "rm"))
(setenv "CC" "gcc")
- (zero? (system* "make" "clean"))))
+ (invoke "make" "clean")))
;; XXX Do we need to recompile the heap image as well for Guix?
;; For now just use the one we already got in the tarball.
(replace 'install