summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-07 00:43:03 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-07 00:44:55 +0200
commit5dfbd7697104ec217f8ed39d711990e27591c1d1 (patch)
tree40ed24bddc5352e5a94c44193c2e418d4255deac
parent879b89d1ae4dc21d3c45d154b0bae586d2dea4f5 (diff)
downloadpatches-5dfbd7697104ec217f8ed39d711990e27591c1d1.tar
patches-5dfbd7697104ec217f8ed39d711990e27591c1d1.tar.gz
gnu: shadow: Correctly match the system type.
* gnu/packages/admin.scm (shadow)[inputs]: Use 'string-contains' instead of 'string-prefix?' when matching the system type.
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 75fba24796..ac8f155fcf 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -324,11 +324,11 @@ hostname.")
(for-each delete-file (find-files man "^groups\\."))
#t))))))
- (inputs (if (string-suffix? "-linux"
- (or (%current-target-system)
- (%current-system)))
- `(("linux-pam" ,linux-pam))
- '()))
+ (inputs (if (string-contains (or (%current-target-system)
+ (%current-system))
+ "-linux")
+ `(("linux-pam" ,linux-pam))
+ '()))
(home-page "http://pkg-shadow.alioth.debian.org/")
(synopsis "Authentication-related tools such as passwd, su, and login")
(description