summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <john@darrington.wattle.id.au>2013-12-14 19:05:17 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-14 22:12:08 +0100
commit5839958a8fff80cb36dcf537903a1d22f6ace0a7 (patch)
tree8f6b9e907530a25b41ec61e1a3aaa84b9fc0adde
parentc94d01bab2714b963048e965955652d0f91ebd56 (diff)
downloadpatches-5839958a8fff80cb36dcf537903a1d22f6ace0a7.tar
patches-5839958a8fff80cb36dcf537903a1d22f6ace0a7.tar.gz
gnu: libxml2: Fixed cross-compilation.
* gnu/packages/xml.scm (libxml2): assign "cross-libc" to the variable glibc. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xml.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index e2bab7b5a8..81e3948f1a 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -75,12 +75,16 @@ things the parser might find in the XML document (like start tags).")
'install
(lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
(let ((install (assoc-ref %standard-phases 'install))
- (glibc (assoc-ref inputs "libc"))
+ (glibc (assoc-ref inputs ,(if (%current-target-system)
+ "cross-libc" "libc")))
(out (assoc-ref outputs "out")))
(apply install args)
(chdir "python")
- (substitute* "setup.py" (("/opt/include") (string-append glibc "/include")))
- (system* "python" "setup.py" "install" (string-append "--prefix=" out))))
+ (substitute* "setup.py"
+ (("/opt/include")
+ (string-append glibc "/include")))
+ (system* "python" "setup.py" "install"
+ (string-append "--prefix=" out))))
%standard-phases)))
(description
"Libxml2 is the XML C parser and toolkit developed for the Gnome project