summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-03-21 12:26:25 +0100
committerLeo Famulari <leo@famulari.name>2020-03-24 17:10:21 -0400
commit3b3edfa8e395b8bc4ea6b8427e2edaa45735e5de (patch)
tree476e8f3e3ce54c92cc49b17578a684e766c036dd
parentf6c784806e130ec42784aeb2c91e62da39aa98bc (diff)
downloadpatches-3b3edfa8e395b8bc4ea6b8427e2edaa45735e5de.tar
patches-3b3edfa8e395b8bc4ea6b8427e2edaa45735e5de.tar.gz
gnu: Add python-json-logger.
* gnu/packages/python-xyz.scm (python-json-logger): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c36134a2bf..66961c0d6b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18550,3 +18550,23 @@ filesystem attributes. Extended attributes extend the basic attributes of files
and directories in the file system. They are stored as name:data pairs
associated with file system objects (files, directories, symlinks, etc).")
(license license:expat)))
+
+(define-public python-json-logger
+ (package
+ (name "python-json-logger")
+ (version "0.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-json-logger" version))
+ (sha256
+ (base32
+ "10g2ya6nsvn5vxzvq2wb8q4d43i3d7756i5rxyjna6d0y9i138xp"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/madzak/python-json-logger")
+ (synopsis "JSON log formatter in Python")
+ (description "This library allows standard Python logging to output log data
+as JSON objects. With JSON we can make our logs more readable by machines and
+we can stop writing custom parsers for syslog-type records.")
+ (license license:bsd-3)))