summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-03-21 12:26:16 +0100
committerLeo Famulari <leo@famulari.name>2020-03-24 17:10:19 -0400
commit2c15cb589832c5c08cbfcd42f64011e2b345e335 (patch)
tree9a13b79cffa85a31d7348f116f3e3bcc111f6fe7
parent5e44011bfb855f448155c2e672e82272a5a2241b (diff)
downloadpatches-2c15cb589832c5c08cbfcd42f64011e2b345e335.tar
patches-2c15cb589832c5c08cbfcd42f64011e2b345e335.tar.gz
gnu: python-pexpect: Update to 4.8.0.
* gnu/packages/python-xyz.scm (python-pexpect): Update to 4.8.0. [arguments]: Disable failing test. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8463fcc6c9..155ad211df 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5339,13 +5339,13 @@ displayed.")
(define-public python-pexpect
(package
(name "python-pexpect")
- (version "4.6.0")
+ (version "4.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pexpect" version))
(sha256
- (base32 "1fla85g47iaxxpjhp9vkxdnv4pgc7rplfy6ja491smrrk0jqi3ia"))))
+ (base32 "032cg337h8awydgypz6f4wx848lw8dyrj4zy988x0lyib4ws8rgw"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -5359,7 +5359,10 @@ displayed.")
;; Many tests try to use the /bin directory which
;; is not present in the build environment.
;; Use one that's non-empty and unlikely to change.
- (("/bin'") "/dev'"))
+ (("/bin'") "/dev'")
+ ;; Disable failing test. See upstream bug report
+ ;; https://github.com/pexpect/pexpect/issues/568
+ (("def test_bash") "def _test_bash"))
;; XXX: Socket connection test gets "Connection reset by peer".
;; Why does it not work? Delete for now.
(delete-file "tests/test_socket.py")